[Openvpn-devel] Fix Ubuntu spelling and duplicate run in Github Actions

Message ID 20210908142724.3391935-1-arne@rfc2549.org
State Accepted
Headers show
Series
  • [Openvpn-devel] Fix Ubuntu spelling and duplicate run in Github Actions
Related show

Commit Message

Arne Schwabe Sept. 8, 2021, 2:27 p.m.
Ubuntu spelling was wrong and the matrix for operating system
does not do anything but run the same build twice.
---
 .github/workflows/build.yaml | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Gert Doering Sept. 10, 2021, 9:54 a.m. | #1
Acked-by: Gert Doering <gert@greenie.muc.de>

"makes sense" :-)

Your patch has been applied to the master branch.

commit 9c4e4751a1cbd90611e652a228884ef6953844a9
Author: Arne Schwabe
Date:   Wed Sep 8 16:27:24 2021 +0200

     Fix Ubuntu spelling and duplicate run in Github Actions

     Acked-by: Gert Doering <gert@greenie.muc.de>
     Message-Id: <20210908142724.3391935-1-arne@rfc2549.org>
     URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg22822.html
     Signed-off-by: Gert Doering <gert@greenie.muc.de>


--
kind regards,

Gert Doering

Patch

diff --git a/.github/workflows/build.yaml b/.github/workflows/build.yaml
index eb2c4f5fe..0d55b8ae0 100644
--- a/.github/workflows/build.yaml
+++ b/.github/workflows/build.yaml
@@ -144,13 +144,13 @@  jobs:
       - name: make check
         run: make check
 
-  ubutun20-clang-asan:
+  ubuntu-clang-asan:
     strategy:
       matrix:
-        os: [ubuntu-16.04, ubuntu-18.04]
+        os: [ubuntu-20.04]
         ssllib: [mbedtls, openssl]
 
-    runs-on: ubuntu-20.04
+    runs-on: ${{matrix.os}}
     steps:
       - name: Install dependencies
         run: sudo apt update && sudo apt install -y liblzo2-dev libpam0g-dev liblz4-dev linux-libc-dev man2html clang libcmocka-dev python3-docutils libtool automake autoconf libmbedtls-dev