[Openvpn-devel,1/3] dev-tools: Remove no longer needed openvpn-plugin.h.in patching

Message ID 20220420121322.42732-1-openvpn@sf.lists.topphemmelig.net
State Accepted
Headers show
Series
  • [Openvpn-devel,1/3] dev-tools: Remove no longer needed openvpn-plugin.h.in patching
Related show

Commit Message

David Sommerseth April 20, 2022, 12:13 p.m.
From: David Sommerseth <davids@openvpn.net>

The bug in uncrustify 0.64 is no longer causing us issues as we now
require at least v0.72.

This workaround was added as part of the initial reformat-all inclusion,
in commit 2417d55c4945d491e.

Signed-off-by: David Sommerseth <davids@openvpn.net>
---
 .../after_include_openvpn-plugin.h.in.patch         | 13 -------------
 .../before_include_openvpn-plugin.h.in.patch        | 13 -------------
 dev-tools/special-files.lst                         |  1 -
 3 files changed, 27 deletions(-)
 delete mode 100644 dev-tools/reformat-patches/after_include_openvpn-plugin.h.in.patch
 delete mode 100644 dev-tools/reformat-patches/before_include_openvpn-plugin.h.in.patch

Comments

Gert Doering April 21, 2022, 7:25 a.m. | #1
Acked-by: Gert Doering <gert@greenie.muc.de>

We've discussed this on IRC - this was a workaround for old uncrustify
(which supposedly segfaulted on openvpn-plugin.h.in) but since we've
converged on "0.72 or 0.74" now, this is no longer relevant.

Your patch has been applied to the master branch.

commit c5c68210c5a38b6ff03d3489aadc519e9a5dd855
Author: David Sommerseth
Date:   Wed Apr 20 14:13:20 2022 +0200

     dev-tools: Remove no longer needed openvpn-plugin.h.in patching

     Signed-off-by: David Sommerseth <davids@openvpn.net>
     Acked-by: Gert Doering <gert@greenie.muc.de>
     Message-Id: <20220420121322.42732-1-openvpn@sf.lists.topphemmelig.net>
     URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg24122.html
     Signed-off-by: Gert Doering <gert@greenie.muc.de>


--
kind regards,

Gert Doering

Patch

diff --git a/dev-tools/reformat-patches/after_include_openvpn-plugin.h.in.patch b/dev-tools/reformat-patches/after_include_openvpn-plugin.h.in.patch
deleted file mode 100644
index 100da078..00000000
--- a/dev-tools/reformat-patches/after_include_openvpn-plugin.h.in.patch
+++ /dev/null
@@ -1,13 +0,0 @@ 
-diff --git a/include/openvpn-plugin.h.in b/include/openvpn-plugin.h.in
-index 05bffab..05b4b6a 100644
---- a/include/openvpn-plugin.h.in
-+++ b/include/openvpn-plugin.h.in
-@@ -169,7 +169,7 @@ typedef void *openvpn_plugin_handle_t;
- /*
-  * We are compiling OpenVPN.
-  */
--/* #define OPENVPN_PLUGIN_DEF        typedef */
-+#define OPENVPN_PLUGIN_DEF        typedef
- #define OPENVPN_PLUGIN_FUNC(name) (*name)
-
- #else  /* ifdef OPENVPN_PLUGIN_H */
diff --git a/dev-tools/reformat-patches/before_include_openvpn-plugin.h.in.patch b/dev-tools/reformat-patches/before_include_openvpn-plugin.h.in.patch
deleted file mode 100644
index 679c4149..00000000
--- a/dev-tools/reformat-patches/before_include_openvpn-plugin.h.in.patch
+++ /dev/null
@@ -1,13 +0,0 @@ 
-diff --git a/include/openvpn-plugin.h.in b/include/openvpn-plugin.h.in
-index 34ad18b..f4c5472 100644
---- a/include/openvpn-plugin.h.in
-+++ b/include/openvpn-plugin.h.in
-@@ -169,7 +169,7 @@ typedef void *openvpn_plugin_handle_t;
- /*
-  * We are compiling OpenVPN.
-  */
--#define OPENVPN_PLUGIN_DEF        typedef
-+// #define OPENVPN_PLUGIN_DEF        typedef
- #define OPENVPN_PLUGIN_FUNC(name) (*name)
-
- #else
diff --git a/dev-tools/special-files.lst b/dev-tools/special-files.lst
index f3f77ea3..64ee9e1a 100644
--- a/dev-tools/special-files.lst
+++ b/dev-tools/special-files.lst
@@ -1,4 +1,3 @@ 
 E:doc/doxygen/doc_key_generation.h     # @verbatim section gets mistreated, exclude it
 E:src/compat/compat-lz4.c              # Preserve LZ4 upstream formatting
 E:src/compat/compat-lz4.h              # Preserve LZ4 upstream formatting
-P:include/openvpn-plugin.h.in          # uncrustify segfaults, patch it before+after