[Openvpn-devel] travis: add OpenSSL 1.1 Windows build

Message ID 20181005123938.25649-1-steffan@karger.me
State Accepted
Headers show
Series
  • [Openvpn-devel] travis: add OpenSSL 1.1 Windows build
Related show

Commit Message

Steffan Karger Oct. 5, 2018, 12:39 p.m.
So we catch both compilation errors against OpenSSL 1.0 and 1.1 on Windows.

Signed-off-by: Steffan Karger <steffan@karger.me>
---
 .travis.yml | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Gert Doering Oct. 5, 2018, 12:48 p.m. | #1
Acked-by: Gert Doering <gert@greenie.muc.de>

Thanks.  As we figured out, we miss testing openssl 1.0 <-> 1.1 for the
windows builds - no we do, and the test results nicely show the "1.0 only"
breakage before Arne's fix that just went in.

Your patch has been applied to the master and release/2.4 branch.

commit a29b60c9577a7ea1302cd761645234a174a7e3cb (master)
commit b8d8e492604b5691c66178605b6c5362f98f6c9d (release/2.4)
Author: Steffan Karger
Date:   Fri Oct 5 14:39:38 2018 +0200

     travis: add OpenSSL 1.1 Windows build

     Signed-off-by: Steffan Karger <steffan@karger.me>
     Acked-by: Gert Doering <gert@greenie.muc.de>
     Message-Id: <20181005123938.25649-1-steffan@karger.me>
     URL: https://www.mail-archive.com/search?l=mid&q=20181005123938.25649-1-steffan@karger.me
     Signed-off-by: Gert Doering <gert@greenie.muc.de>


--
kind regards,

Gert Doering
Илья Шипицин Oct. 5, 2018, 12:49 p.m. | #2
openssl versions were aligned to those used in "openvpn-build" repo, i.e.
the same version were used as in installer creation.
not sure why do we want to have big matrix for cross builds.

but I do not mind, the more tests the better :)

пт, 5 окт. 2018 г. в 17:40, Steffan Karger <steffan@karger.me>:

> So we catch both compilation errors against OpenSSL 1.0 and 1.1 on Windows.
>
> Signed-off-by: Steffan Karger <steffan@karger.me>
> ---
>  .travis.yml | 5 ++++-
>  1 file changed, 4 insertions(+), 1 deletion(-)
>
> diff --git a/.travis.yml b/.travis.yml
> index 216f0a04..ede2aaa6 100644
> --- a/.travis.yml
> +++ b/.travis.yml
> @@ -53,7 +53,10 @@ matrix:
>        os: osx
>        osx_image: xcode7.3
>        compiler: clang
> -    - env: SSLLIB="openssl" CHOST=x86_64-w64-mingw32
> +    - env: SSLLIB="openssl" CHOST=x86_64-w64-mingw32
> OPENSSL_VERSION="1.0.1u"
> +      os: linux
> +      compiler: ": Win64 build only"
> +    - env: SSLLIB="openssl" CHOST=x86_64-w64-mingw32
> OPENSSL_VERSION="1.1.0h"
>        os: linux
>        compiler: ": Win64 build only"
>      - env: SSLLIB="openssl" CHOST=i686-w64-mingw32
> --
> 2.17.1
>
>
>
> _______________________________________________
> Openvpn-devel mailing list
> Openvpn-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/openvpn-devel
>
<div dir="ltr"><div>openssl versions were aligned to those used in &quot;openvpn-build&quot; repo, i.e. the same version were used as in installer creation.</div><div>not sure why do we want to have big matrix for cross builds.</div><div><br></div><div>but I do not mind, the more tests the better :)<br></div></div><br><div class="gmail_quote"><div dir="ltr">пт, 5 окт. 2018 г. в 17:40, Steffan Karger &lt;<a href="mailto:steffan@karger.me">steffan@karger.me</a>&gt;:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">So we catch both compilation errors against OpenSSL 1.0 and 1.1 on Windows.<br>
<br>
Signed-off-by: Steffan Karger &lt;<a href="mailto:steffan@karger.me" target="_blank">steffan@karger.me</a>&gt;<br>
---<br>
 .travis.yml | 5 ++++-<br>
 1 file changed, 4 insertions(+), 1 deletion(-)<br>
<br>
diff --git a/.travis.yml b/.travis.yml<br>
index 216f0a04..ede2aaa6 100644<br>
--- a/.travis.yml<br>
+++ b/.travis.yml<br>
@@ -53,7 +53,10 @@ matrix:<br>
       os: osx<br>
       osx_image: xcode7.3<br>
       compiler: clang<br>
-    - env: SSLLIB=&quot;openssl&quot; CHOST=x86_64-w64-mingw32<br>
+    - env: SSLLIB=&quot;openssl&quot; CHOST=x86_64-w64-mingw32 OPENSSL_VERSION=&quot;1.0.1u&quot;<br>
+      os: linux<br>
+      compiler: &quot;: Win64 build only&quot;<br>
+    - env: SSLLIB=&quot;openssl&quot; CHOST=x86_64-w64-mingw32 OPENSSL_VERSION=&quot;1.1.0h&quot;<br>
       os: linux<br>
       compiler: &quot;: Win64 build only&quot;<br>
     - env: SSLLIB=&quot;openssl&quot; CHOST=i686-w64-mingw32<br>
-- <br>
2.17.1<br>
<br>
<br>
<br>
_______________________________________________<br>
Openvpn-devel mailing list<br>
<a href="mailto:Openvpn-devel@lists.sourceforge.net" target="_blank">Openvpn-devel@lists.sourceforge.net</a><br>
<a href="https://lists.sourceforge.net/lists/listinfo/openvpn-devel" rel="noreferrer" target="_blank">https://lists.sourceforge.net/lists/listinfo/openvpn-devel</a><br>
</blockquote></div>
Gert Doering Oct. 5, 2018, 12:51 p.m. | #3
Hi,

On Fri, Oct 05, 2018 at 05:49:17PM +0500, ???????? ?????????????? wrote:
> openssl versions were aligned to those used in "openvpn-build" repo, i.e.
> the same version were used as in installer creation.
> not sure why do we want to have big matrix for cross builds.
> 
> but I do not mind, the more tests the better :)

With the cryptoapi code, we have code paths now that are "only windows"
and "care needs to be taken for openssl 1.0 <-> 1.1" (RSA_meth_set_sign()).

That's the new thing...

gert

Patch

diff --git a/.travis.yml b/.travis.yml
index 216f0a04..ede2aaa6 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -53,7 +53,10 @@  matrix:
       os: osx
       osx_image: xcode7.3
       compiler: clang
-    - env: SSLLIB="openssl" CHOST=x86_64-w64-mingw32
+    - env: SSLLIB="openssl" CHOST=x86_64-w64-mingw32 OPENSSL_VERSION="1.0.1u"
+      os: linux
+      compiler: ": Win64 build only"
+    - env: SSLLIB="openssl" CHOST=x86_64-w64-mingw32 OPENSSL_VERSION="1.1.0h"
       os: linux
       compiler: ": Win64 build only"
     - env: SSLLIB="openssl" CHOST=i686-w64-mingw32