[Openvpn-devel] Document comp-lzo no and compress being incompatible

Message ID 20181024113341.1242-1-arne@rfc2549.org
State New
Headers show
Series
  • [Openvpn-devel] Document comp-lzo no and compress being incompatible
Related show

Commit Message

Arne Schwabe Oct. 24, 2018, 11:33 a.m.
Most of the new compress but not v2 version do use swap operation. For
'compress lzo' the swap option is not used for backwards compatibility.
For lz4 the swap option is also not a problem since there is no version
without swap. Unfortunately, compress introduced a second stub format
with swap, contrary to the one in 'comp-lzo no' that does not use swap.

Document this weirdness to let not others fall into this trap.
---
 doc/openvpn.8 | 3 +++
 1 file changed, 3 insertions(+)

Comments

David Sommerseth Oct. 26, 2018, 11:31 a.m. | #1
On 24/10/18 13:33, Arne Schwabe wrote:
> Most of the new compress but not v2 version do use swap operation. For
> 'compress lzo' the swap option is not used for backwards compatibility.
> For lz4 the swap option is also not a problem since there is no version
> without swap. Unfortunately, compress introduced a second stub format
> with swap, contrary to the one in 'comp-lzo no' that does not use swap.
> 
> Document this weirdness to let not others fall into this trap.
> ---
>  doc/openvpn.8 | 3 +++
>  1 file changed, 3 insertions(+)

This patch does not apply to git master .... which commit is this based on?
Arne Schwabe Oct. 26, 2018, 2:48 p.m. | #2
Am 26.10.18 um 13:31 schrieb David Sommerseth:
> On 24/10/18 13:33, Arne Schwabe wrote:
>> Most of the new compress but not v2 version do use swap operation. For
>> 'compress lzo' the swap option is not used for backwards compatibility.
>> For lz4 the swap option is also not a problem since there is no version
>> without swap. Unfortunately, compress introduced a second stub format
>> with swap, contrary to the one in 'comp-lzo no' that does not use swap.
>>
>> Document this weirdness to let not others fall into this trap.
>> ---
>>  doc/openvpn.8 | 3 +++
>>  1 file changed, 3 insertions(+)
> 
> This patch does not apply to git master .... which commit is this based on?
> 
> 

The allow-compression patch.

Arne

Patch

diff --git a/doc/openvpn.8 b/doc/openvpn.8
index ac923f51..f8aa94ae 100644
--- a/doc/openvpn.8
+++ b/doc/openvpn.8
@@ -2551,6 +2551,9 @@  offering the best performance with least CPU usage.
 For backwards compatibility with OpenVPN versions before v2.4, use "lzo"
 (which is identical to the older option "\-\-comp\-lzo yes").
 
+Note however that the `stub` (or empty) option is NOT compatible with the
+older option "\-\-comp\-lzo no").
+
 The "lz4\-v2" and "stub\-v2" variants implement a better framing that does not add
 overhead when packets cannot be compressed. All other variants always add one extra
 framing byte compared to no compression framing.