[Openvpn-devel,2/2] travis-ci: update components versions

Message ID 20190628194637.5038-3-chipitsine@gmail.com
State Accepted, archived
Delegated to: Gert Doering
Headers show
Series
  • travis-ci osx fix and components update
Related show

Commit Message

Илья Шипицин June 28, 2019, 7:46 p.m.
From: Ilya Shipitsin <chipitsine@gmail.com>

tap windows, pkcs11 helper, mbedtls, openssl were updated to the most recent versions

Signed-off-by: Ilya Shipitsin <chipitsine@gmail.com>
---
 .travis.yml | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

Comments

Gert Doering July 2, 2019, 7:08 a.m. | #1
Acked-by: Gert Doering <gert@greenie.muc.de>

Seems like a good idea to move to the most current library versions
(let's see what will explode :) ).

Your patch has been applied to the master branch.

commit 9f04bf189981517162d82549886f7496497b69a8
Author: Ilya Shipitsin
Date:   Sat Jun 29 00:46:37 2019 +0500

     travis-ci: update components versions

     Signed-off-by: Ilya Shipitsin <chipitsine@gmail.com>
     Acked-by: Gert Doering <gert@greenie.muc.de>
     Message-Id: <20190628194637.5038-3-chipitsine@gmail.com>
     URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg18619.html
     Signed-off-by: Gert Doering <gert@greenie.muc.de>


--
kind regards,

Gert Doering

Patch

diff --git a/.travis.yml b/.travis.yml
index 7a074d34..2d07cdc3 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -9,13 +9,13 @@  env:
   global:
     - JOBS=3
     - PREFIX="${HOME}/opt"
-    - TAP_WINDOWS_VERSION=9.21.2
+    - TAP_WINDOWS_VERSION=9.23.3
     - LZO_VERSION=2.10
-    - PKCS11_HELPER_VERSION=1.22
-    - MBEDTLS_VERSION="2.8.0"
+    - PKCS11_HELPER_VERSION=1.25.1
+    - MBEDTLS_VERSION=2.16.1
     - MBEDTLS_CFLAGS="-I${PREFIX}/include"
     - MBEDTLS_LIBS="-L${PREFIX}/lib -lmbedtls -lmbedx509 -lmbedcrypto"
-    - OPENSSL_VERSION="1.0.2o"
+    - OPENSSL_VERSION=1.0.2s
     - OPENSSL_CFLAGS="-I${PREFIX}/include"
     - OPENSSL_LIBS="-L${PREFIX}/lib -lssl -lcrypto"
     # The next declaration is the encrypted COVERITY_SCAN_TOKEN, created
@@ -30,10 +30,10 @@  matrix:
     - env: SSLLIB="openssl" OPENSSL_VERSION="1.0.1u"
       os: linux
       compiler: gcc
-    - env: SSLLIB="openssl" OPENSSL_VERSION="1.1.0h"
+    - env: SSLLIB="openssl" OPENSSL_VERSION="1.1.1c"
       os: linux
       compiler: gcc
-    - env: SSLLIB="openssl" OPENSSL_VERSION="1.1.0h" LABEL="linux-ppc64le"
+    - env: SSLLIB="openssl" OPENSSL_VERSION="1.1.1c" LABEL="linux-ppc64le"
       os: linux-ppc64le
       compiler: gcc
     - env: SSLLIB="openssl" EXTRA_CONFIG="--enable-iproute2"
@@ -42,7 +42,7 @@  matrix:
     - env: SSLLIB="openssl" CFLAGS="-fsanitize=address"
       os: linux
       compiler: clang
-    - env: SSLLIB="openssl" OPENSSL_VERSION="1.1.0h"
+    - env: SSLLIB="openssl" OPENSSL_VERSION="1.1.1c"
       os: linux
       compiler: clang
     - env: SSLLIB="mbedtls"
@@ -60,7 +60,7 @@  matrix:
     - env: SSLLIB="openssl" CHOST=x86_64-w64-mingw32 OPENSSL_VERSION="1.0.1u"
       os: linux
       compiler: ": Win64 build only"
-    - env: SSLLIB="openssl" CHOST=x86_64-w64-mingw32 OPENSSL_VERSION="1.1.0h"
+    - env: SSLLIB="openssl" CHOST=x86_64-w64-mingw32 OPENSSL_VERSION="1.1.1c"
       os: linux
       compiler: ": Win64 build only"
     - env: SSLLIB="openssl" CHOST=i686-w64-mingw32