[Openvpn-devel] Doc openvpn.8: Add deprecation notice to --compress

Message ID 20211126144331.2400062-1-tincantech@protonmail.com
State Not Applicable
Headers show
Series [Openvpn-devel] Doc openvpn.8: Add deprecation notice to --compress | expand

Commit Message

Richard T Bonhomme Nov. 26, 2021, 2:43 p.m. UTC
Signed-off-by: Richard T Bonhomme <tincantech@protonmail.com>
---
 doc/openvpn.8 | 1 +
 1 file changed, 1 insertion(+)

Comments

Antonio Quartulli Nov. 26, 2021, 2:48 p.m. UTC | #1
Hi,

On 26/11/2021 15:43, Richard T Bonhomme wrote:
> Signed-off-by: Richard T Bonhomme <tincantech@protonmail.com>
> ---
>   doc/openvpn.8 | 1 +
>   1 file changed, 1 insertion(+)
> 
> diff --git a/doc/openvpn.8 b/doc/openvpn.8
> index 598d5fce..dfe0ad10 100644
> --- a/doc/openvpn.8
> +++ b/doc/openvpn.8
> @@ -2501,6 +2501,7 @@ limit repetitive logging of similar message types.
>   .\"*********************************************************
>   .TP
>   .B \-\-compress [algorithm]
> +.B DEPRECATED
>   Enable a compression algorithm.
>   
>   The

We already have this. Against what branch did you create this patch?

Cheers,
Kristof Provost via Openvpn-devel Nov. 28, 2021, 1:27 a.m. UTC | #2
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Seems I jumped the gun a little..

NACK, --compress is not deprecated in 2.4

Sorry
R


Sent with ProtonMail Secure Email.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Friday, November 26th, 2021 at 14:48, Antonio Quartulli <a@unstable.cc> wrote:

> Hi,
>
> On 26/11/2021 15:43, Richard T Bonhomme wrote:
>
> > Signed-off-by: Richard T Bonhomme tincantech@protonmail.com
> > -----------------------------------------------------------
> >
> > doc/openvpn.8 | 1 +
> >
> > 1 file changed, 1 insertion(+)
> >
> > diff --git a/doc/openvpn.8 b/doc/openvpn.8
> >
> > index 598d5fce..dfe0ad10 100644
> >
> > --- a/doc/openvpn.8
> >
> > +++ b/doc/openvpn.8
> >
> > @@ -2501,6 +2501,7 @@ limit repetitive logging of similar message types.
> >
> > .\"*********************************************************
> >
> > .TP
> >
> > .B \-\-compress [algorithm]
> >
> > +.B DEPRECATED
> >
> > Enable a compression algorithm.
> >
> > The
>
> We already have this. Against what branch did you create this patch?
>
> Cheers,
>
> --------------------------------------------------------------------------------
>
> Antonio Quartulli
>
> Openvpn-devel mailing list
>
> Openvpn-devel@lists.sourceforge.net
>
> https://lists.sourceforge.net/lists/listinfo/openvpn-devel
-----BEGIN PGP SIGNATURE-----
Version: ProtonMail

wsBzBAEBCAAGBQJhotroACEJEE+XnPZrkLidFiEECbw9RGejjXJ5xVVVT5ec
9muQuJ1VPgf+O45rGSxFsovrhOa2OQ3r9DFCiG8Wsc51hs24jqH8CJd7fiaI
Bqy3ZIJsxi/PQocn2JCqE0odfFSiHOQVLpGEkCS2dSnbOG7wrA+LKqWbuTMu
xnly3U0a1ekMwunKbXxE6tGgQXrS0aBPkcx5oNWyxvFGNruYoDUwHkOex2zh
mUvjQS1F/TWxwBaXm/2awzBOLghIqUNE+l+Fm5eAN+025jUP9g3TUVlxBF6S
j6FOjIEXukN75t/K01g2ME/P4RJgvjNcRLw2kQewD8ajtGJhweRQKyaFQOJY
xSKE3ePA7wWoTVX0xpY41Gruin3usMXwL6XeU3/WyX6CLZY5nQIQ4g==
=nFcI
-----END PGP SIGNATURE-----
Gert Doering Nov. 28, 2021, 8:54 a.m. UTC | #3
Hi,

On Sun, Nov 28, 2021 at 01:27:19AM +0000, tincantech via Openvpn-devel wrote:
> Seems I jumped the gun a little..
> 
> NACK, --compress is not deprecated in 2.4

If you send patches for something that is not "master", it must be
made clear in some way - either in the Subject: line, or in the commit
message ("this patch is for 2.4 only because ...")

gert

Patch

diff --git a/doc/openvpn.8 b/doc/openvpn.8
index 598d5fce..dfe0ad10 100644
--- a/doc/openvpn.8
+++ b/doc/openvpn.8
@@ -2501,6 +2501,7 @@  limit repetitive logging of similar message types.
 .\"*********************************************************
 .TP
 .B \-\-compress [algorithm]
+.B DEPRECATED
 Enable a compression algorithm.
 
 The