| Message ID | 20190812134513.20758-1-arne@rfc2549.org |
|---|---|
| State | Superseded |
| Headers |
Return-Path: <openvpn-devel-bounces@lists.sourceforge.net> Delivered-To: patchwork@openvpn.net Delivered-To: patchwork@openvpn.net Received: from director12.mail.ord1d.rsapps.net ([172.27.255.50]) by backend30.mail.ord1d.rsapps.net with LMTP id ED3LI8dtUV39NgAAIUCqbw for <patchwork@openvpn.net>; Mon, 12 Aug 2019 09:46:47 -0400 Received: from proxy10.mail.iad3a.rsapps.net ([172.27.255.50]) by director12.mail.ord1d.rsapps.net with LMTP id kEMQIcdtUV3fWQAAIasKDg ; Mon, 12 Aug 2019 09:46:47 -0400 Received: from smtp53.gate.iad3a ([172.27.255.50]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) by proxy10.mail.iad3a.rsapps.net with LMTP id GHCeGsdtUV2eRwAAnQ/bqA ; Mon, 12 Aug 2019 09:46:47 -0400 X-Spam-Threshold: 95 X-Spam-Score: 0 X-Spam-Flag: NO X-Virus-Scanned: OK X-Orig-To: openvpnslackdevel@openvpn.net X-Originating-Ip: [216.105.38.7] Authentication-Results: smtp53.gate.iad3a.rsapps.net; iprev=pass policy.iprev="216.105.38.7"; spf=pass smtp.mailfrom="openvpn-devel-bounces@lists.sourceforge.net" smtp.helo="lists.sourceforge.net"; dkim=fail (signature verification failed) header.d=sourceforge.net; dkim=fail (signature verification failed) header.d=sf.net; dmarc=none (p=nil; dis=none) header.from=rfc2549.org X-Suspicious-Flag: YES X-Classification-ID: 9f805f12-bd07-11e9-8973-5254009c3572-1-1 Received: from [216.105.38.7] ([216.105.38.7:38782] helo=lists.sourceforge.net) by smtp53.gate.iad3a.rsapps.net (envelope-from <openvpn-devel-bounces@lists.sourceforge.net>) (ecelerity 4.2.38.62370 r(:)) with ESMTPS (cipher=DHE-RSA-AES256-GCM-SHA384) id 86/56-10052-5CD615D5; Mon, 12 Aug 2019 09:46:45 -0400 Received: from [127.0.0.1] (helo=sfs-ml-2.v29.lw.sourceforge.com) by sfs-ml-2.v29.lw.sourceforge.com with esmtp (Exim 4.90_1) (envelope-from <openvpn-devel-bounces@lists.sourceforge.net>) id 1hxAdd-0002Kf-Pr; Mon, 12 Aug 2019 13:45:29 +0000 Received: from [172.30.20.202] (helo=mx.sourceforge.net) by sfs-ml-2.v29.lw.sourceforge.com with esmtps (TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256) (Exim 4.90_1) (envelope-from <arne@kamera.blinkt.de>) id 1hxAdc-0002KY-Rm for openvpn-devel@lists.sourceforge.net; Mon, 12 Aug 2019 13:45:28 +0000 DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=sourceforge.net; s=x; h=Message-Id:Date:Subject:To:From:Sender:Reply-To:Cc: MIME-Version:Content-Type:Content-Transfer-Encoding:Content-ID: Content-Description:Resent-Date:Resent-From:Resent-Sender:Resent-To:Resent-Cc :Resent-Message-ID:In-Reply-To:References:List-Id:List-Help:List-Unsubscribe: List-Subscribe:List-Post:List-Owner:List-Archive; bh=LCZ7ESPD3h2HJrwqYpI4CMdMnp6SUkC/nT+1M2jyKuc=; b=Ypn1TOUOjOgCgkOK1esI9ulNoW lqBXO8Srn5SB0rKH9KFoIg/Nbyg1Cy9/Lb0s5++wHjLNyYfSWt0AZ5QxDHrfDu2+nlJ1zBjZC5u23 MzqBAnxysYo6IKOFrkAu7KMVVyO4HJcLUUQUSGAvkmJ15/TKsmjGsWoP/hL38SNAE9OU=; DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=sf.net; s=x ; h=Message-Id:Date:Subject:To:From:Sender:Reply-To:Cc:MIME-Version: Content-Type:Content-Transfer-Encoding:Content-ID:Content-Description: Resent-Date:Resent-From:Resent-Sender:Resent-To:Resent-Cc:Resent-Message-ID: In-Reply-To:References:List-Id:List-Help:List-Unsubscribe:List-Subscribe: List-Post:List-Owner:List-Archive; bh=LCZ7ESPD3h2HJrwqYpI4CMdMnp6SUkC/nT+1M2jyKuc=; b=TpdWycvKYwpYHy1DB40SXTgPNy YqX2JpR8pC71Y8rvka9JZkjrS9C2Q5JmxOP4pWGSkagPbnOvma20ICB7baRtBn/Xb3iBeYANDTVnM sYGCjGJLMhaRAqKF2lbie0i9zoqGbBSKuibWzJaKkIbNX0tW4DooIOvLPvyCB3FiQ+Uc=; Received: from mail.blinkt.de ([192.26.174.232]) by sfi-mx-4.v28.lw.sourceforge.com with esmtps (TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256) (Exim 4.90_1) id 1hxAdW-000hSz-VO for openvpn-devel@lists.sourceforge.net; Mon, 12 Aug 2019 13:45:28 +0000 Received: from kamera.blinkt.de ([2001:638:502:390:20c:29ff:fec8:535c]) by mail.blinkt.de with smtp (Exim 4.92 (FreeBSD)) (envelope-from <arne@kamera.blinkt.de>) id 1hxAdN-00058p-88 for openvpn-devel@lists.sourceforge.net; Mon, 12 Aug 2019 15:45:13 +0200 Received: (nullmailer pid 20803 invoked by uid 10006); Mon, 12 Aug 2019 13:45:13 -0000 From: Arne Schwabe <arne@rfc2549.org> To: openvpn-devel@lists.sourceforge.net Date: Mon, 12 Aug 2019 15:45:12 +0200 Message-Id: <20190812134513.20758-1-arne@rfc2549.org> X-Mailer: git-send-email 2.17.1 X-Spam-Report: Spam Filtering performed by mx.sourceforge.net. See http://spamassassin.org/tag/ for more details. 0.2 HEADER_FROM_DIFFERENT_DOMAINS From and EnvelopeFrom 2nd level mail domains are different 0.0 SPF_NONE SPF: sender does not publish an SPF Record 0.0 SPF_HELO_NONE SPF: HELO does not publish an SPF Record 0.5 AWL AWL: Adjusted score from AWL reputation of From: address X-Headers-End: 1hxAdW-000hSz-VO Subject: [Openvpn-devel] [PATCH 1/2] Fix check if iface name is set X-BeenThere: openvpn-devel@lists.sourceforge.net X-Mailman-Version: 2.1.21 Precedence: list List-Id: <openvpn-devel.lists.sourceforge.net> List-Unsubscribe: <https://lists.sourceforge.net/lists/options/openvpn-devel>, <mailto:openvpn-devel-request@lists.sourceforge.net?subject=unsubscribe> List-Archive: <http://sourceforge.net/mailarchive/forum.php?forum_name=openvpn-devel> List-Post: <mailto:openvpn-devel@lists.sourceforge.net> List-Help: <mailto:openvpn-devel-request@lists.sourceforge.net?subject=help> List-Subscribe: <https://lists.sourceforge.net/lists/listinfo/openvpn-devel>, <mailto:openvpn-devel-request@lists.sourceforge.net?subject=subscribe> MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Errors-To: openvpn-devel-bounces@lists.sourceforge.net X-getmail-retrieved-from-mailbox: Inbox |
| Series |
[Openvpn-devel,1/2] Fix check if iface name is set
|
|
Commit Message
Arne Schwabe
Aug. 12, 2019, 3:45 a.m. UTC
Clang/Android complained
warning: address of array 'rgi6->iface' will always evaluate to 'true' [-Wpointer-bool-conversion]
if (rgi6->iface)
iface is a char[16]; So its pointer is always true.
we do a CLEAR(rgi6) always before setting this struct and strcpy the
name into iface. So using strlen instead of checking for the pointer
should be the right fix.
---
src/openvpn/route.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Comments
Hi Arne, On 12/08/2019 15:45, Arne Schwabe wrote: > Clang/Android complained > > warning: address of array 'rgi6->iface' will always evaluate to 'true' [-Wpointer-bool-conversion] > if (rgi6->iface) > > iface is a char[16]; So its pointer is always true. > > we do a CLEAR(rgi6) always before setting this struct and strcpy the > name into iface. So using strlen instead of checking for the pointer > should be the right fix. Thanks for fixing this! However you're missing the signed off line. > --- > src/openvpn/route.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/src/openvpn/route.c b/src/openvpn/route.c > index 5f63fd34..a302746e 100644 > --- a/src/openvpn/route.c > +++ b/src/openvpn/route.c > @@ -3349,7 +3349,7 @@ get_default_gateway_ipv6(struct route_ipv6_gateway_info *rgi6, > rgi6->flags |= RGI_ADDR_DEFINED; > } > > - if (rgi6->iface) > + if (strlen(rgi6->iface)) how about adding a "> 0"? I know it's basically the same here, but I think that's the style we use everywhere. Cheers, > { > rgi6->flags |= RGI_IFACE_DEFINED; > } >
On 13/08/2019 11:03, Antonio Quartulli wrote: > Hi Arne, > > On 12/08/2019 15:45, Arne Schwabe wrote: >> Clang/Android complained >> >> warning: address of array 'rgi6->iface' will always evaluate to 'true' [-Wpointer-bool-conversion] >> if (rgi6->iface) >> >> iface is a char[16]; So its pointer is always true. >> >> we do a CLEAR(rgi6) always before setting this struct and strcpy the >> name into iface. So using strlen instead of checking for the pointer >> should be the right fix. > > Thanks for fixing this! > > However you're missing the signed off line. > > >> --- >> src/openvpn/route.c | 2 +- >> 1 file changed, 1 insertion(+), 1 deletion(-) >> >> diff --git a/src/openvpn/route.c b/src/openvpn/route.c >> index 5f63fd34..a302746e 100644 >> --- a/src/openvpn/route.c >> +++ b/src/openvpn/route.c >> @@ -3349,7 +3349,7 @@ get_default_gateway_ipv6(struct route_ipv6_gateway_info *rgi6, >> rgi6->flags |= RGI_ADDR_DEFINED; >> } >> >> - if (rgi6->iface) >> + if (strlen(rgi6->iface)) > > how about adding a "> 0"? I know it's basically the same here, but I > think that's the style we use everywhere. Agreed, but just thinking aloud ... since we use CLEAR() and this is a static allocated buffer; constant size always "readable" - wouldn't it be better to do 'if (rgi6->iface[0])' instead? Since the buffer should be NULL terminated and has to be NULL terminted for strlen() to function anyhow. But the compiled code would be a bit more efficient (even though, this isn't necessarily a performance critical code section).
Hi, On 13/08/2019 23:26, David Sommerseth wrote: > wouldn't it be better to > do 'if (rgi6->iface[0])' instead? Since the buffer should be NULL terminated > and has to be NULL terminted for strlen() to function anyhow. But the > compiled code would be a bit more efficient (even though, this isn't > necessarily a performance critical code section). In my opinion strlen() is more readable for the casual developer checking this code. Behind iface[0] we may hide other ambiguous assumptions (even though this is not the case here, but we won't remember in some months from now). Cheers,
Hi, On 13-08-19 23:31, Antonio Quartulli wrote: > On 13/08/2019 23:26, David Sommerseth wrote: >> wouldn't it be better to >> do 'if (rgi6->iface[0])' instead? Since the buffer should be NULL terminated >> and has to be NULL terminted for strlen() to function anyhow. But the >> compiled code would be a bit more efficient (even though, this isn't >> necessarily a performance critical code section). > > In my opinion strlen() is more readable for the casual developer > checking this code. Behind iface[0] we may hide other ambiguous > assumptions (even though this is not the case here, but we won't > remember in some months from now). Antionio's answer is of course the real reason to use strlen(), but you nerd-sniped me by saying "compiled code would be a bit more efficient". As you said, that wouldn't matter here, but still: compilers nowadays do optimize calls to strlen, memset, memcpy, etc. The following code #include <string.h> int test(const char *buf) { return (strlen(buf) > 0); } for example compiles with -O3 on my GCC 8.3 to 0000000000000000 <test>: 0: 31 c0 xor %eax,%eax 2: 80 3f 00 cmpb $0x0,(%rdi) 5: 0f 95 c0 setne %al 8: c3 retq which indeed just compares the first byte of the buffer against zero. So, unless there are important performance constraints, let's optimize code for readability, rather than performance :) FOOOOM [0] -Steffan [0] https://xkcd.com/356/
On 13/08/2019 23:46, Steffan Karger wrote: > Hi, > > On 13-08-19 23:31, Antonio Quartulli wrote: >> On 13/08/2019 23:26, David Sommerseth wrote: >>> wouldn't it be better to >>> do 'if (rgi6->iface[0])' instead? Since the buffer should be NULL terminated >>> and has to be NULL terminted for strlen() to function anyhow. But the >>> compiled code would be a bit more efficient (even though, this isn't >>> necessarily a performance critical code section). >> >> In my opinion strlen() is more readable for the casual developer >> checking this code. Behind iface[0] we may hide other ambiguous >> assumptions (even though this is not the case here, but we won't >> remember in some months from now). > > Antionio's answer is of course the real reason to use strlen(), but you > nerd-sniped me by saying "compiled code would be a bit more efficient". > As you said, that wouldn't matter here, but still: compilers nowadays do > optimize calls to strlen, memset, memcpy, etc. > > The following code > > #include <string.h> > > int test(const char *buf) { > return (strlen(buf) > 0); > } > > for example compiles with -O3 on my GCC 8.3 to > > 0000000000000000 <test>: > 0: 31 c0 xor %eax,%eax > 2: 80 3f 00 cmpb $0x0,(%rdi) > 5: 0f 95 c0 setne %al > 8: c3 retq > > which indeed just compares the first byte of the buffer against zero. > > So, unless there are important performance constraints, let's optimize > code for readability, rather than performance :) Cool! Thanks! I didn't run such a check, as I really didn't expect the compiler to be _that_ smart ... but I agree with you both, and especially when the end result is optimized for both readability *and* performance ;-)
diff --git a/src/openvpn/route.c b/src/openvpn/route.c index 5f63fd34..a302746e 100644 --- a/src/openvpn/route.c +++ b/src/openvpn/route.c @@ -3349,7 +3349,7 @@ get_default_gateway_ipv6(struct route_ipv6_gateway_info *rgi6, rgi6->flags |= RGI_ADDR_DEFINED; } - if (rgi6->iface) + if (strlen(rgi6->iface)) { rgi6->flags |= RGI_IFACE_DEFINED; }